50

answers

1

vote

Vote

internet-networking in Internet & Networking Channel,
Written by: Richard Bashara on May 21 2010, 7:01pm

ResolvedUnderlined Hyper Links in WebEasy | Easy Web Design

Fellow Citizens:

I want more control over what my links look like on the page as I build it in WebEasy Professional.  Sometimes I want to have links that are underlined, sometimes not.  It would also be nice to remove the underline when the end user hovers over something clickable. 

Does anyone have any thoughts on how this works? Where would I go in WebEasy to make this work?

50 Citizens Answers

Tim Browning says:

And there you have found WebEasy's downfall ... customisation of and indeed access to the HTML is a right pain in the posterior! In a full-on HTML package, you would simple add an inline style or assign the specific tag a class from the stylesheet.

In the brief 10 minute flirt I had with WebEasy, I found no way of getting at the actual HTML, which for me made it a no-no. Granted it is excellent software for the uninitiated, but for those who want to dig deeper, there seems no easy way to get at the nuts and bolts of a webpage.

Maybe someone will prove me wrong? I would love that to be the case as I have a couple of staff who need HTML software, but don't need something as complicated, or as expensive, as Dreamweaver.

0

Votes

Vote
May 22 2010, 2:21pm | Report

Arthur K. says:

Now i'm going to assume you want to make ALL links on your page not have underlines. There is a way to do it to just some links, but that would involve create a new css style class.

To make ALL links on the website not underline... Please note i said Website, not Webpage. These instructions will change link styles on all the pages on your website, not just the current page.

1) Open up the project in webeasy
2) Click on View >> Inspector ; so that the Inspector toolbar is viewable on the right side of your screen.
3) Click on any link on your page, so that it is highlighted.
4) In the Inspector, click on the Style tab
5) Locate "STYLE CLASS" (should be 4th from top). Double click on the white box next to it.
6) You will need to change the:
<A:HOVER>
<A:LINK>
<A:VISITED>

To do this:
1) Click on <A:Hover>
2) Click on Edit>> so it will display you more options to click on, such as Modify, New Class, Add Links, Import All, Delete, Delete All.
3) Click on Modify
4) Locate the line "Custom CSS". Double click the white box to the right of it.
5) This will open up a Cascade Style Sheet Assistant. Modify the text so that it reads: text-decoration :none;
6) Click OK
7) Click OK again
8) CLICK ON UPDATE at the bottom right. Gotta make sure you click update or the changes wont take place.

Now when you preview your site, all your links should not underline.

 

 

@Tim Browning:

 

Although webeasy does not have a "code view" it has several tools available to insert your own custom coding.

The true heart of webeasy is in the File Inspector. You can, for the most part, modify the lines of CSS that webeasy generates through the style section.

Also, in version 8, inserting your own custom html or javascript into the <body> is very simple. Click on Insert >> Component >> Html Code Fragment.

Paste or write your code in the text field that will the open. Once complete it, place the item onto the page. WebEasy will then insert a "place-holder" in that position. When you view the page in a browser (doing a preview in webeasy), that placeholder will have been replaced with the custom coding.

It is almost as imple if you need to insert custom coding into the <head> section. There is a attribute in the File Inspector called Head Element. If you modify the value to the right of that attribute, any text that you insert will be inserted in the <head> section of the source code.

3

Votes

Vote
Aug 5 2010, 2:41pm | Report
Best answer!

delicia wells says:

I have Web Easy Professional 8 and when I click on Inspector toolbar then the Style bar and I located the Style Class but for my surprise I don't have HOVER, LINK and VISITED only N/A...Can someone help...

0

Votes

Vote
Aug 23 2010, 2:47pm | Report

Arthur K. says:

You are selecting the sub category style class.

Expand the sub-category Item (should have a blue background).

When you expand Item, the 2nd attribute should be Style Class.

1

Vote

Vote
Aug 24 2010, 8:58am | Report

Miguel Zamudio says:

I tried doing the same. Expanded "Item" double clicked on the white bar and "hover" "linked" nor "visited" is anywhere to be found. feel free to email me at migizam@gmail.com

0

Votes

Vote
Aug 31 2010, 6:15pm | Report

Arthur K. says:

If those items are not listed, this means you need to add them. You most likely used a blank template, so it did not have link styles created already.

When you double lcicked on the white bar and the Page Style box opens, click  the Edit >> button so that it will open the edit menu on the left.

From there, click the Add Links button.

 

4

Votes

Vote
Sep 1 2010, 9:00am | Report

Anthony Curran says:

Ok done above and it worked from the fact the it doesn't underline when building as html with css but it does still change the font colour from what i build it as. How i stop it doing that? Again thanks for all you help.

0

Votes

Vote
Oct 29 2010, 11:12am | Report

Arthur K. says:

Anthony,

Text color and link color are two different things.

If you make the text a color, then turn that text into a link, it is no longer text. It will not use the text color. It will adopt the color assigned to links. You would need to locate the:

<A:HOVER>
<A:LINK>
<A:VISITED>,

and modify the colors assigned to those items to the colors you desire.

2

Votes

Vote
Oct 29 2010, 11:24am | Report

Anthony Curran says:

Great thanks for your help. That has worked. Last question which is back to the original. When change the title in file name it come up ok but if i call say Anthony Curran then it comes up like www.somewebsite.ie/Anthony%20Curran.htm How can i fix that?

 

Again thanks for everything you have been a great help.

0

Votes

Vote
Oct 29 2010, 12:05pm | Report

Arthur K. says:

Anthony,

Spaces are not valid characters web design. When spaces are used, they are converted to %20.

What you can do, however, is use underscores "_". You could name the file Anthony_Curran.htm.

 

1

Vote

Vote
Oct 29 2010, 6:30pm | Report

Erica McCabe says:

Is there a way to change individual links to look different than the "standard" that you have set?  Example - if I want to make some linked text have a smaller font than other linked text.

0

Votes

Vote
Mar 2 2011, 2:52pm | Report

Arthur K. says:

Hello Erica,

Yes there is. What you would need to do is create a new style class, then create links for that style class, set the colors you wish for that style class to display, and then assign that style class to the objects you wish to use those settings.

1) Open up the project in webeasy
2) Click on View >> Inspector ; so that the Inspector toolbar is viewable on the right side of your screen.
3) Click on any link on your page, so that it is highlighted.
4) In the Inspector, click on the Style tab
5) Locate "STYLE CLASS" (should be 4th from top). Double click on the white box next to it.
6) Click the Edit>> button to expand and see all the available options.
7) Click on New Class. Assign that class a name, and select any color (this is for the class, not for links. If you are only going to be using that class for links, it makes no difference what you set at this moment. However, if you wish to use that same style class for other text boxes, you can set it to your desired settings) and click OK.
8) You should now see that newly created style class on the Document Styles box. Click on it to select it and then click on Add Links.

This will then create the :hover, :link, and :visited items for that style class. Simply select each one and edit the style attributes to your desire.

 

1

Vote

Vote
Mar 3 2011, 11:49am | Report

sarah agosta says:

Hi Arthur,

I've followed your instructions although it is changing the colour of all the links on the page. How do i make sure some links have the new class and some have the old?

0

Votes

Vote
May 12 2011, 7:21am | Report

sarah agosta says:

Hi again, I've created a new class and when i preview the page it is working perfectly, i've just published the page and all the links have changed back to the same colour?

0

Votes

Vote
May 12 2011, 7:45am | Report

Arthur K. says:

Sarah,

It sounds as though you were able to answer your first question (regarding having some links in one color and the other links in another color) but I will post my answer in case any other users have the same question.

If you wish to have links with different colors, you would need to have multiple style class. Each style class would then have it's own set of standard link, visited link, and active link colors. You would then specify the style class you wish for that text object to reflect.

 

As for your other issue, the way the page appears when you do a preview should be how it appears when published. If it is not, there could be a few reasons why.

1) You are viewing a cached version of the page from your local temporary internet files folder. Try clearing your temporary internet files and reload the page to ensure that you are viewing the latest files from the hosting server.

 

2) You index page was not set to index.html (or whatever your previous index page was set to) to overwrite the old index page with the new one. This would result in the new files being uploaded, however the hosting server still displaying the old index page when viewers visit your web site. Please make sure that your index page is set to index.html and reupload.

0

Votes

Vote
May 12 2011, 10:37am | Report

sarah agosta says:

Thanks so much Arthur, I cleared all temp files.

0

Votes

Vote
May 13 2011, 4:04am | Report

brent peters says:

Arthur -

I'm stuck where Miguel was above.  I'm using WebEasy8, started with a blank document and I'm trying to rid my (text) links of underlines.  With the Inspector open I clicked on the Page Style box but didn't find an Edit option.

thanks Brent

0

Votes

Vote
Jun 30 2011, 5:58pm | Report

Arthur K. says:

Brent,

After you open the File Inspector, click on the Style tab.

Under the sub-category Item, you should see Style Class. If you double click on the white field next to Style Class, it will open the Page Style window. On the top right of that Window, you should see "Edit>>".

2

Votes

Vote
Jul 1 2011, 11:43am | Report

brent peters says:

nice, that did it!  It eliminated the link's unwanted color and underline which is perfect. Amazing how deep you are forced to drill into the program to find that info. Thanks again Arthur

0

Votes

Vote
Jul 6 2011, 1:14pm | Report

tom shen says:

i dont see the "white space"

do u mean when i click on the style class and the white space inside it?

even if i did that and a properties window popped up it dosnt have the edit button

and if i selected a link all the fields will say n/a

 

help!!!!!!!

0

Votes

Vote
Jul 18 2011, 7:47pm | Report

Arthur K. says:

Tom,

In the File Inspector, under the Style tab, expand the Sub Category "Item". There you will see an attribute titled Style Class. To the right of it will be a blank white field under Value. Double click the blank white field. Once you do that, it will open the Page Style window.

0

Votes

Vote
Jul 19 2011, 11:41am | Report

brent peters says:

Tom -

Listen to whatever Arthur tells you to do, he knows all

0

Votes

Vote
Jul 20 2011, 12:26pm | Report

tom shen says:

thx i got it

 

0

Votes

Vote
Jul 20 2011, 2:41pm | Report

Madelein Cornelius says:

Hi Arthur

I urgently need help with the following:

When building my (blank) website (html with css) it changes the font colour from what i build it as.  I have tried the following u suggested to Anthony: 

You would need to locate the:

<A:HOVER>

<A:LINK>

<A:VISITED>,

and modify the colors assigned to those items to the colors you desire.

When i select or stand on <A:hover> on Page Style, i can see the preview foreground colour (red), when i select Modify to change the colour, the Style Class Properties (Modify) opens, Name: <A:hover> appears (that,s it).  Where can I modify the colour?

MaybeI am missing something, but I have been struggling with this for the entire  day.  Hope u can assist me.

Thanks, Madelein

 

0

Votes

Vote
Apr 19 2012, 5:33am | Report

Arthur K. says:

Madelein,

When you open the Style Class Properties window, it should have a list of attributes. The very first attribute is Foreground Color. Double click the value field to the right of this attribute and select your desired color.

1

Vote

Vote
Apr 19 2012, 11:14am | Report

Madelein Cornelius says:

Hi Arthur THANK YOU!!! It worked. I would also like to find out from you: I want to create a login / administrator login form area (example on the home page), for my clients to login to the site I created (with my Webeasy 9) where they can amend pictures / text and also to login with username and password from the website into another linked site. Hope that you can assist me - please let me know if you don't understand what I am looking for. Regards, Madelein
0

Votes

Vote
Apr 19 2012, 3:59pm | Report

Madelein Cornelius says:

Hi Arthur, me again

Referringto my  previous request; creating a login form, I see that on the softcity page you can also login via Facebook, it's something like that, I am looking for.

Regards, Madelein

 

 

0

Votes

Vote
Apr 19 2012, 4:17pm | Report

Arthur K. says:

Madelein,

You would need to use your own custom coding to create such a thing. WebEasy does not have such a feature.

0

Votes

Vote
Apr 20 2012, 10:23am | Report

Leanne Dodd says:

Hi, i am also trying to get rid of the underlining on the links, but when i go to the white box next to style class it says unknown in it, and if double click on it a box comes up saying unknown style class definition, do i want to remove the style classes? ;-/

Please help 

0

Votes

Vote
Jul 2 2012, 7:16am | Report

Arthur K. says:

Leanne,

 In the File Inspector, expand the Item Sub Category and locate the Style Class attribute listed there. You are most likely looking at the Style Class Sub-Category itself. 

0

Votes

Vote
Jul 2 2012, 10:49am | Report

Leanne Dodd says:

I have done that, when i open the sub category a list comes up, font, align, transparent, background, gradient, texture etc.. with blank white boxes next to them. The box next to style class is blue and does not do anything when i double click on it. 

0

Votes

Vote
Jul 3 2012, 3:30pm | Report

Leanne Dodd says:

Please help ;-/

0

Votes

Vote
Jul 5 2012, 3:44pm | Report

Arthur Roberts says:

I have done everything listed on this page for a style called navigation and no matter what I don't it won't honor hover or page link.  It works with the page style though.  Any ideas?

 

Thanks,

Arthur

0

Votes

Vote
Jul 8 2012, 9:59am | Report

Arthur K. says:

Leanne,

Once again, you are expanding the Style Class sub-category.
We need you to expand the Item sub-category (the blue bar that states item) then double click the Style Class attribute (with a white background) below it.  

0

Votes

Vote
Jul 9 2012, 1:16pm | Report

Arthur K. says:

Arthur,

What exactly do you mean that it will not honor? I think we would need to see your actual file to see what exactly is happening. Can you please visit our support page and submit an e-mail trouble ticket so that we can have you e-mail us a copy of your project as well as more details as to what exactly you are trying to do.  

0

Votes

Vote
Jul 9 2012, 1:17pm | Report

Leanne Dodd says:

I am doing that, but the white box has the word "unknown" in it.  I double click on it and a box comes up stating "unknown style class definition in the selection, it maybe possible that global class has been deleted, or the document was created by another product edition, do you wish to remove the style class from the selected items? "

 

Leanne

0

Votes

Vote
Jul 11 2012, 2:31am | Report

Leanne Dodd says:

Woooohhooo forget that last message!   its worked, thanks for your help  ;-)

0

Votes

Vote
Jul 11 2012, 2:51am | Report

Leanne Dodd says:

Hi, i know how to change the colour of the links but when i change the colour then all the links on my website change to that colour.  Is there anyway i can only change certain links to certain colours??

 

Leanne

 

0

Votes

Vote
Jul 17 2012, 4:52am | Report

Arthur K. says:

Leanne,

You would need to create a new style class. You would then add links to that style class and specify the colors you wish to use for links associated with that style class. Then, you can assign that style class to the object. It will then adopt those link colors set for that style class.

The responses in this thread show you how to get to the style class window and how to add style classes and so forth.  

0

Votes

Vote
Jul 17 2012, 10:06am | Report

Leanne Dodd says:

ok thanks, now i am having problems when uploading my website, it all looks fine on webeasy and then as soon as its uploaded i have pictures in places i didnt 

want pictures and the font and size of links are different, do you know why?

 

Leanne

0

Votes

Vote
Jul 24 2012, 2:55am | Report

Arthur K. says:

Leanne,

Does it display properly when you preview the page in a web browser locally?
Go to the Review and Tools tab and Preview All Site Pages.

0

Votes

Vote
Jul 25 2012, 4:21pm | Report

Leanne Dodd says:

yeah it looks fine when i preview it ;-/

0

Votes

Vote
Jul 29 2012, 3:47am | Report

Arthur K. says:

Leanne,

The way it appears during a preview is generally how it will appear once published. I would suggest going through the build process to build the new html package once again, then republishing that newly built html package.
Once it has finished uploading, clear your temporary internet cache/web history and reload the page to view it.

0

Votes

Vote
Jul 30 2012, 10:53am | Report

Madelein Cornelius says:

Hi Arthur

Hi, i am also trying to get rid of the underlining on the links, but when i go to the  File Inspector, click on Style and expand the Item Sub Category and locate the Style Class attribute list, the box next to it is white and when I double click on it, the Page Style opens - "hover", "visited" and "link" appears.  When I click on Hover, I can see the Foreground with my following info Foreground Color:  #BB9100Font:  Century Gothic, 10pt, BoldCustom CSS:   text-decoration :underline.  

How can I get rid of the underline?

I also suspect that the underline is the reason why my drop-down menu doesn't work.

Regards, Madelein

0

Votes

Vote
Sep 6 2012, 4:56am | Report

Arthur K. says:

Madelein,

 Click the "Edit >>" button. This will expand the window, giving you more options.
One of the options there is Modify. Select the class you wish to edit and press the Modify button.

 

0

Votes

Vote
Sep 6 2012, 11:08am | Report

John Phillips says:

HELP.....................!!!!

 

I am using Web Easy Pro8... or should I say trying to use.

I have followed the Instruction above to the letter. To get rid of the underline... on a LINK, but I can not get pass the Page Style window opening... part of the instructions. I tried the instructions so many times my keypad is wearing out.

What I see when the PAGE STYLE window opens

 

Top Left of window - All Styles (Combo Box) which when selected has the drop down has "All Styles", "Document Styles", "Global Styles" for selection

 

Below this is a box with

(Normal - no style)

address

citation

code

emphasis

heading1

heading2

heading3

heading4

heading5

heading6

small

 

 

At the TOP  is a heading "Preview Global Class"           Edit <<

with a box below

 

 

SO AT WHAT POINT SHOULD I SEE <A:HOVER> <A:LINK> <A:VISITED>

 

I assume from the written instruction above I should be seeing that TEXT somewhere on the screen.... BUT I don't..!

 

 

What I hope to do is eventually change the links for different pages so that font colours do not clash with backgrounds... as they do at present...

 

I want some White link text to turn green on roll over... and stay white after visited...

 

others to be green font turning a different green on roll over... then to be black after visited

 

There will in the end be multiple styles for the website

 

I hope that this makes sense...

 

- John

0

Votes

Vote
Sep 9 2012, 8:47am | Report

Arthur K. says:

John,

The file you are working with did not contain a link style class. You would need to press the ADD LINKS button to add the link styles. You can also create a new style class, and add links to that style class, if you want to create different link colors for different pages.  

0

Votes

Vote
Sep 10 2012, 11:27am | Report

Lisa B says:

Sending you a huge Thank You Arthur!  This information was awesome and saved me!

0

Votes

Vote
Jan 9 2013, 2:23pm | Report

Sue Dent says:

. . . so where would the ADD LINKS button be located? . . . ummm . . . never mind. It seems that Murphy's law wins out again. I don't find the thing I'm looking for UNTIL I ask someone if they might can tell me where it is. Got it!! And yes Arthur K. thanks so much for these post. ;)

 

0

Votes

Vote
Mar 15 2013, 9:30am | Report

Arthur K. says:

Sue,

When you open the Page Style window, there is a button that says "Edit>>"
Click on it to display more options.  

0

Votes

Vote
Mar 18 2013, 1:01pm | Report

Post your comment

default Avatar

You might be interested in these related contributions

About the Author

Richard Bashara

Los Angeles, California, US

1499 contributions

I'm Richard and I write about what happens when I break software